CVE-2008-5153 — moodle
CVE-2008-5153 is a CWE-59 vulnerability in moodle/moodle. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle vulnerable to symlink attack
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
spell-check-logic.cgi in Moodle 1.9 before 1.9.4, 1.8 before 1.8.8, 1.7 before 1.7.7 and 1.6 before 1.6.9 allows local users to overwrite arbitrary files via a symlink attack on the (1) /tmp/spell-check-debug.log, (2) /tmp/spell-check-before, or (3) /tmp/spell-check-after temporary file.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 1.9.0&&< 1.9.4 | 1.9.4composer require moodle/moodle:^1.9.4 |
| 🐘Packagist | moodle/moodle | ≥ 1.8.0&&< 1.8.8 | 1.8.8composer require moodle/moodle:^1.8.8 |
| 🐘Packagist | moodle/moodle | ≥ 1.7.0&&< 1.7.7 | 1.7.7composer require moodle/moodle:^1.7.7 |
| 🐘Packagist | moodle/moodle | ≥ 1.6.0&&< 1.6.9 | 1.6.9composer require moodle/moodle:^1.6.9 |
Affected Products
moodlemoodleResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 1.9.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2008-5153 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2008-5153 in your dependencies?
Find it across Packagist, including transitive dependencies.