CVE-2008-3909 is a high-severity (CVSS 7.5) Cross-Site Request Forgery (CSRF) vulnerability in django. A fix is available for django — see the affected versions and patch details below.
Django cross-site request forgery (CSRF) vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
django🐍django🐍djangoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The administration application in Django 0.91, 0.95, and 0.96 stores unauthenticated HTTP POST requests and processes them after successful authentication occurs, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks and delete or modify data via unspecified requests.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | django | ≥ 0.91.0&&< 0.91.3 | 0.91.3pip install --upgrade 'django==0.91.3' |
| 🐍PyPI | django | ≥ 0.95.0&&< 0.95.4 | 0.95.4pip install --upgrade 'django==0.95.4' |
| 🐍PyPI | django | ≥ 0.96.0&&< 0.96.3 | 0.96.3pip install --upgrade 'django==0.96.3' |
Affected Products
djangodjangoprojectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update django to 0.91.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2008-3909 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2008-3909 in your dependencies?
Find it across PyPI, including transitive dependencies.