NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2008-2717 — cms-core

CVE-2008-2717 is a CWE-264 vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.

TYPO3 Unrestricted File Upload vulnerability

Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
0.00%1.29%2.57%3.86%0.2%3.0%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

3 pkgs affected
🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

TYPO3 4.0.x before 4.0.9, 4.1.x before 4.1.7, and 4.2.x before 4.2.1, uses an insufficiently restrictive default fileDenyPattern for Apache, which allows remote attackers to bypass security restrictions and upload configuration files such as .htaccess, or conduct file upload attacks using multiple extensions.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms-core≥ 4.0.0&&< 4.0.94.0.9composer require typo3/cms-core:^4.0.9
🐘Packagisttypo3/cms-core≥ 4.1.0&&< 4.1.74.1.7composer require typo3/cms-core:^4.1.7
🐘Packagisttypo3/cms-core≥ 4.2.0&&< 4.2.14.2.1composer require typo3/cms-core:^4.2.1

Affected Products

2 products · 18 configurations
Application
apache webserverapache
all
Application
typo3typo3
17 versions
4.04.0.14.0.24.0.34.0.44.0.54.0.64.0.74.0.84.14.1.14.1.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms-core to 4.0.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2008-2717 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

TYPO3 4.0.x before 4.0.9, 4.1.x before 4.1.7, and 4.2.x before 4.2.1, uses an insufficiently restrictive default fileDenyPattern for Apache, which allows remote attackers to bypass security restrictions and upload configuration files such as .htaccess, or conduct file upload attacks using multiple extensions.
O3 Security · Impact-Aware SCA

Is CVE-2008-2717 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2008-2717: cms-core — Fixed in 4.0.9