NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2008-2302 — django

MEDIUMFix: django/django@50ce7fb

CVE-2008-2302 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in django. A fix is available for django — see the affected versions and patch details below.

Django Cross-site scripting (XSS) vulnerability

Also known asGHSA-54qj-48vx-cr9fPYSEC-2008-1
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk-0.01%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.00%0.61%1.22%1.82%0.4%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍django🐍django🐍django

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the login form in the administration application in Django 0.91 before 0.91.2, 0.95 before 0.95.3, and 0.96 before 0.96.2 allows remote attackers to inject arbitrary web script or HTML via the URI of a certain previous request.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjango≥ 0.91&&< 0.91.20.91.2pip install --upgrade 'django==0.91.2'
🐍PyPIdjango≥ 0.95&&< 0.95.30.95.3pip install --upgrade 'django==0.95.3'
🐍PyPIdjango≥ 0.96&&< 0.96.20.96.2pip install --upgrade 'django==0.96.2'

Affected Products

1 product · 3 configurations
Application
djangodjango_project
3 versions
0.910.950.96

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django to 0.91.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2008-2302 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the login form in the administration application in Django 0.91 before 0.91.2, 0.95 before 0.95.3, and 0.96 before 0.96.2 allows remote attackers to inject arbitrary web script or HTML via the URI of a certain previous request.
O3 Security · Impact-Aware SCA

Is CVE-2008-2302 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2008-2302: django XSS — Fixed in 0.91.2