CVE-2007-1355 — jsp-api
CVE-2007-1355 is a security vulnerability in org.apache.tomcat:jsp-api. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.tomcat:jsp-api — see the affected versions and patch details below.
Apache Tomcat Vulnerable to Cross-Site Scripting
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:jsp-api☕org.apache.tomcat:jsp-api☕org.apache.tomcat:jsp-api☕org.apache.tomcat:jsp-api☕org.apache.tomcat:jsp-api☕org.apache.tomcat:servlet-api☕org.apache.tomcat:servlet-api☕org.apache.tomcat:servlet-api+2 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Multiple cross-site scripting (XSS) vulnerabilities in the appdev/sample/web/hello.jsp example application in Tomcat 4.0.0 through 4.0.6, 4.1.0 through 4.1.36, 5.0.0 through 5.0.30, 5.5.0 through 5.5.23, and 6.0.0 through 6.0.10 allow remote attackers to inject arbitrary web script or HTML via the test parameter and unspecified vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:jsp-api | ≥ 4.1.0&&< 4.1.37 | 4.1.37org.apache.tomcat:jsp-api:4.1.37 |
| ☕Maven | org.apache.tomcat:jsp-api | ≥ 5.5.0&&< 5.5.24 | 5.5.24org.apache.tomcat:jsp-api:5.5.24 |
| ☕Maven | org.apache.tomcat:jsp-api | ≥ 6.0.0&&< 6.0.11 | 6.0.11org.apache.tomcat:jsp-api:6.0.11 |
| ☕Maven | org.apache.tomcat:jsp-api | ≥ 5.0.0 | No fix |
| ☕Maven | org.apache.tomcat:jsp-api | ≥ 4.0.0 | No fix |
| ☕Maven | org.apache.tomcat:servlet-api | ≥ 4.1.0&&< 4.1.37 | 4.1.37org.apache.tomcat:servlet-api:4.1.37 |
Affected Products
tomcatapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Apache Tomcat 6.0.10 - Documentation Sample Application Multiple Cross-Site Scripting Vulnerabilities
by Ferruh Mavituna · May 19, 2007
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:jsp-api, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:jsp-api to 4.1.37 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2007-1355 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Network Satellite Server v 4.2 | jabberd-0:2.0s10-3.38.rhn | RHSA-2008:0524 |
| Red Hat Network Satellite Server v 5.0 | jabberd-0:2.0s10-3.38.rhn | RHSA-2008:0261 |
| Red Hat Network Satellite Server v 5.1 | jfreechart-0:0.9.20-3.rhn | RHSA-2008:0630 |
Frequently Asked Questions
Is CVE-2007-1355 in your dependencies?
Find it across Maven, including transitive dependencies.