NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
Withdrawn — this advisory has been retracted
📦 Debian:10
Not in CISA KEV

CVE-2007-0857 — moin

CVE-2007-0857 is a security vulnerability in moin. A fix is available for moin — see the affected versions and patch details below.

MoinMoin Multiple cross-site scripting (XSS) vulnerabilities

Also known asGHSA-m84w-vgwf-p893PYSEC-2026-678
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.72%1.45%2.19%2.92%1.2%2.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
📦moin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Debian:10 packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin before 1.5.7 allow remote attackers to inject arbitrary web script or HTML via (1) the page info, or the page name in a (2) AttachFile, (3) RenamePage, or (4) LocalSiteMap action.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦Debian:10moinall versions1.5.3-1.2

Affected Products

1 product · 11 configurations
Application
moinmoinmoinmoin
≤ 1.5.6
10 versions
1.5.01.5.11.5.21.5.31.5.3_rc11.5.3_rc21.5.41.5.51.5.5_rc11.5.5a

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moin to 1.5.3-1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2007-0857 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin before 1.5.7 allow remote attackers to inject arbitrary web script or HTML via (1) the page info, or the page name in a (2) AttachFile, (3) RenamePage, or (4) LocalSiteMap action.
O3 Security · Impact-Aware SCA

Is CVE-2007-0857 in your dependencies?

Find it across Debian:10, including transitive dependencies.

CVE-2007-0857: moin XSS — Fixed in 1.5.3-1.2