CVE-2006-4247 — plone
CRITICALCVE-2006-4247 is a critical-severity (CVSS 9.1) vulnerability in plone. A fix is available for plone — see the affected versions and patch details below.
Plone allows anonymous users to reset any users password through the web via Password Reset Tool
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ploneReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Unspecified vulnerability in the Password Reset Tool before 0.4.1 on Plone 2.5 and 2.5.1 Release Candidate allows attackers to reset the passwords of other users, related to "an erroneous security declaration."
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | plone | ≥ 2.5&&< 2.5.1 | 2.5.1pip install --upgrade 'plone==2.5.1' |
Affected Products
ploneploneDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for plone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update plone to 2.5.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2006-4247 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2006-4247 in your dependencies?
Find it across PyPI, including transitive dependencies.