# GHSA-pxx3-g568-hxr4: color-convert — Fixed in 3.1.2

📦 npm

Not in CISA KEV

# color-convert@3.1.1 contains malware after npm account takeoverGHSA-pxx3-g568-hxr4

GHSA-pxx3-g568-hxr4 is a CWE-506 vulnerability in color-convert. A fix is available for color-convert — see the affected versions and patch details below.

Also known as[CVE-2025-59162](/vulnerability/CVE-2025-59162)[GHSA-ch7m-m9rf-8gvv](/vulnerability/GHSA-ch7m-m9rf-8gvv)MAL-2025-46971

Published

Sep 15, 2025

Updated

Sep 16, 2025

Affected

1 pkg

Patched

1 / 1

Exploits

None indexed

Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

## Exploitation Status

### No confirmed exploitation observed yet

-   CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
-   CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-pxx3-g568-hxr4.

## EPSS Exploitation Probability

[via FIRST.org ↗](https://www.first.org/epss/)

0.4%probability of exploitation in next 30 days

Lower Risk0.00%

Lower risk than most CVEs37th percentile — riskier than 37% of all scored CVEsHighest risk

0.00%0.31%0.62%0.93%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from [FIRST.org EPSS](https://www.first.org/epss/).

## Real-World Exposure

1 pkg affected

📦`color-convert`

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects npm packages — download data is not available via public APIs for these ecosystems.

## Description

#### Impact

On 8 September 2025, the npm publishing account for `color-convert` was taken over after a phishing attack. Version `3.1.1` was published, functionally identical to the previous patch version, but with a malware payload added attempting to redirect cryptocurrency transactions to the attacker's own addresses from within browser environments.

Local environments, server environments, command line applications, etc. are not affected. If the package was used in a browser context (e.g. a direct `<script>` inclusion, or via a bundling tool such as Babel, Rollup, Vite, Next.js, etc.) there is a chance the malware still exists and such bundles will need to be rebuilt.

The malware seemingly only targets cryptocurrency transactions and wallets such as MetaMask. See references below for more information on the payload.

#### Patches

npm removed the offending package from the registry over the course of the day on 8 September, preventing further downloads from npm proper.

On 13 September, the package owner published new patch versions to help cache-bust those using private registries who might still have the compromised version cached. This version is functionally identical to the previously known-good version, published as a patch version bump above the compromised version.

Users should update to the latest patch version, completely remove their `node_modules` directory, clean their package manager's global cache, and rebuild any browser bundles from scratch.

Those operating private registries or registry mirrors should purge the offending versions from any caches.

#### References

-   [https://www.aikido.dev/blog/npm-debug-and-chalk-packages-compromised](https://www.aikido.dev/blog/npm-debug-and-chalk-packages-compromised)
-   [https://socket.dev/blog/npm-author-qix-compromised-in-major-supply-chain-attack](https://socket.dev/blog/npm-author-qix-compromised-in-major-supply-chain-attack)
-   [https://www.ox.security/blog/npm-packages-compromised/](https://www.ox.security/blog/npm-packages-compromised/)

#### Point of Contact

In the event suspicious behavior is still observed for the package listed in this security advisory after performing all of the above cleaning operations (see _Patches_ above), please reach out via one of the following channels of communication:

-   Bluesky, package owner: [https://bsky.app/profile/bad-at-computer.bsky.social](https://bsky.app/profile/bad-at-computer.bsky.social)
-   `debug` repository, tracking issue (applies to all packages affected in the breach): [https://github.com/debug-js/debug/issues/1005](https://github.com/debug-js/debug/issues/1005)

## Affected Packages

1 total 1 fixed

Ecosystem

Package

Vulnerable range

Fix

📦npm

`color-convert` 

≥ 3.1.1&&< 3.1.2

3.1.2`npm install color-convert@3.1.2`

## Detection & mitigation playbook

Open-source dependency

1.  ### Detect
    
    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for color-convert, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
    
2.  ### Fix
    
    Update color-convert to 3.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pxx3-g568-hxr4 is resolved across your whole dependency graph.
    
3.  ### Workarounds
    
    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
    

## Frequently Asked Questions

\### Impact On 8 September 2025, the npm publishing account for \`color-convert\` was taken over after a phishing attack. Version \`3.1.1\` was published, functionally identical to the previous patch version, but with a malware payload added attempting to redirect cryptocurrency transactions to the attacker's own addresses from within browser environments. Local environments, server environments, command line applications, etc. are not affected. If the package was used in a browser context (e.g. a direct \`<script>\` inclusion, or via a bundling tool such as Babel, Rollup, Vite, Next.js, etc.) there

O3 Security · Impact-Aware SCA

### Is GHSA-pxx3-g568-hxr4 in your dependencies?

Find it across npm, including transitive dependencies.

[Scan my dependencies](/book-demo) [How O3 SCA works](/impact-aware-sca)