# CVE-2025-61588: risc0-zkvm-platform RCE — Fixed in 2.1.0

🦀 crates.io

Not in CISA KEV

# CVE-2025-61588 — risc0-zkvm-platform

[Fix: risc0/risc0@3f00e1f](https://github.com/risc0/risc0/commit/3f00e1fa0159599c1601e788021f2169d1f0a4dc)

CVE-2025-61588 is a Code Injection vulnerability in risc0-zkvm-platform. A fix is available for risc0-zkvm-platform — see the affected versions and patch details below.

risc0 vulnerable to arbitrary code execution in guest via memory safety failure in \`sys\_read\`

Also known as[GHSA-jqq4-c7wq-36h7](/vulnerability/GHSA-jqq4-c7wq-36h7)

Published

Oct 1, 2025

Updated

Oct 28, 2026

Affected

5 pkgs

Patched

5 / 5

Exploits

None indexed

Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

## Exploitation Status

### No confirmed exploitation observed yet

-   CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
-   A successful exploit gives an attacker total control of the affected component, not partial access.
-   CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-61588.

## EPSS Exploitation Probability

[via FIRST.org ↗](https://www.first.org/epss/)

0.5%probability of exploitation in next 30 days

Lower Risk0.00%

Lower risk than most CVEs40th percentile — riskier than 40% of all scored CVEsHighest risk

0.00%0.32%0.64%0.96%0.1%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from [FIRST.org EPSS](https://www.first.org/epss/).

## Real-World Exposure

5 pkgs affected

🦀`risc0-zkvm-platform`🦀`risc0-zkos-v1compat`🦀`risc0-aggregation`🦀`risc0-zkvm`🦀`risc0-zkvm`

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

## Description

## Arbitrary code execution in guest via memory safety failure in `sys_read`

In affected versions of `risc0-zkvm-platform`, when the zkVM guest calls `sys_read`, the host is able to use a crafted response to write to an arbitrary memory location in the guest. This capability can be leveraged to execute arbitrary code within the guest. As `sys_read` is the mechanism by which input is requested by the guest, all guest programs built with the affected versions are vulnerable. This critically compromises the soundness guarantees of the guest program.

A fix was applied in [#3351](https://github.com/risc0/risc0/pull/3351). The vulnerable pointer arithmetic was removed, and replaced with a simplified implementation in the `v1compat` kernel which uses Rust’s slice functions to guarantee memory safety.

The fix has been released as part of `risc0-zkvm` versions `2.3.2` and `3.0.3`. All prior versions are affected.

### Remediation

All developers of zkVM applications should update their guests to use `risc0-zkvm` versions `^2.3.2` or `^3.0.3`.

This upgrade can be accomplished by editing all `Cargo.toml` files in the following way.

-   Any references to [`risc0-zkvm`](https://crates.io/crates/risc0-zkvm) should use version specifiers `”2.3.2”` or `”3.0.3”`.
-   Any references to [`risc0-build`](https://crates.io/crates/risc0-build) should use version specifiers `”2.3.2”` or `”3.0.3”`, matching `risc0-zkvm`.
-   Any references to [`risc0-zkvm-platform`](https://crates.io/crates/risc0-zkvm-platform) should use version specifier `”2.1.0”` or later. Most projects will not have direct references to this crate.

Rebuild your application including the guest. You can run the following command to check that the patch is applied:

```
# Provide the path to your guest Cargo.toml. Should report risc0-zkvm-platform >=v2.1.0
cargo tree --depth 0 -p risc0-zkvm-platform --manifest-path path/to/methods/guest/Cargo.toml
```

Any applications that use the image ID of this guest need to be updated with the newly built image ID.

Note that there are no changes to the RISC Zero proof system or circuits. Provers are not required to take any action. Users of the Groth16 smart contract verifier and the [RISC Zero Verifier Router](https://dev.risczero.com/api/blockchain-integration/contracts/verifier#verifier-router) are not required to take any action beyond updating their guest programs.

Any applications using the `risc0-aggregation` crate or the `RiscZeroSetVerifier` smart contract should update to version `>=0.9`. This application includes a zkVM guest, which is vulnerable in versions prior to `0.9`. Instances of the `RiscZeroSetVerifier` operated by RISC Zero have been disabled via the estop mechanism outlined in the [Verifier Management Design](https://github.com/risc0/risc0-ethereum/blob/release-2.0/contracts/version-management-design.md#base-verifier-implementations).

## Affected Packages

5 total 5 fixed

Ecosystem

Package

Vulnerable range

Fix

🦀crates.io

`risc0-zkvm-platform` 

all versions

2.1.0`cargo update -p risc0-zkvm-platform --precise 2.1.0`

🦀crates.io

`risc0-zkos-v1compat` 

all versions

2.1.0`cargo update -p risc0-zkos-v1compat --precise 2.1.0`

🦀crates.io

`risc0-aggregation` 

all versions

0.9`cargo update -p risc0-aggregation --precise 0.9`

🦀crates.io

`risc0-zkvm` 

all versions

2.3.2`cargo update -p risc0-zkvm --precise 2.3.2`

🦀crates.io

`risc0-zkvm` 

≥ 3.0.0&&< 3.0.3

3.0.3`cargo update -p risc0-zkvm --precise 3.0.3`

## Detection & mitigation playbook

Open-source dependency

1.  ### Detect
    
    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for risc0-zkvm-platform, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
    
2.  ### Fix
    
    Update risc0-zkvm-platform to 2.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-61588 is resolved across your whole dependency graph.
    
3.  ### Workarounds
    
    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
    

## Frequently Asked Questions

\# Arbitrary code execution in guest via memory safety failure in \`sys\_read\` In affected versions of \`risc0-zkvm-platform\`, when the zkVM guest calls \`sys\_read\`, the host is able to use a crafted response to write to an arbitrary memory location in the guest. This capability can be leveraged to execute arbitrary code within the guest. As \`sys\_read\` is the mechanism by which input is requested by the guest, all guest programs built with the affected versions are vulnerable. This critically compromises the soundness guarantees of the guest program. A fix was applied in \[\\#3351\](https://github.c

O3 Security · Impact-Aware SCA

### Is CVE-2025-61588 in your dependencies?

Find it across crates.io, including transitive dependencies.

[Scan my dependencies](/book-demo) [How O3 SCA works](/impact-aware-sca)