# CVE-2025-54575: SixLabors DoS — Fixed in 2.1.11

.NET

.NET NuGet

Not in CISA KEV

MEDIUM severity

# CVE-2025-54575 — SixLabors.ImageSharp

MEDIUM [Fix: SixLabors/ImageSharp@55e4926](https://github.com/SixLabors/ImageSharp/commit/55e49262df9a057dff9b7807ed1b7bdb49187c3f)

CVE-2025-54575 is a medium-severity (CVSS 5.3) Uncontrolled Resource Consumption vulnerability in SixLabors.ImageSharp. A fix is available for SixLabors.ImageSharp — see the affected versions and patch details below.

ImageSharp Triggers an Infinite Loop in its GIF Decoder When Skipping Malformed Comment Extension Blocks

Also known as[GHSA-rxmq-m78w-7wmc](/vulnerability/GHSA-rxmq-m78w-7wmc)

Published

Jul 30, 2025

Updated

Oct 28, 2026

Affected

2 pkgs

Patched

2 / 2

Exploits

None indexed

Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

## Exploitation Status

### Proof-of-concept exploit code exists

-   CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
-   CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-54575.

## EPSS Exploitation Probability

[via FIRST.org ↗](https://www.first.org/epss/)

0.4%probability of exploitation in next 30 days

Lower Risk0.00%

Lower risk than most CVEs39th percentile — riskier than 39% of all scored CVEsHighest risk

0.00%0.32%0.63%0.95%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from [FIRST.org EPSS](https://www.first.org/epss/).

## How urgent is this, really

## Where this sits among everything scored

## Real-World Exposure

2 pkgs affected

.NET`SixLabors.ImageSharp`.NET`SixLabors.ImageSharp`

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

## Description

ImageSharp is a 2D graphics library. In versions below 2.1.11 and 3.0.0 through 3.1.10, a specially crafted GIF file containing a malformed comment extension block (with a missing block terminator) can cause the ImageSharp GIF decoder to enter an infinite loop while attempting to skip the block. This leads to a denial of service. Applications processing untrusted GIF input should upgrade to a patched version. This issue is fixed in versions 2.1.11 and 3.1.11.

## Affected Packages

2 total 2 fixed

Ecosystem

Package

Vulnerable range

Fix

.NETNuGet

`SixLabors.ImageSharp` 

all versions

2.1.11`dotnet add package SixLabors.ImageSharp --version 2.1.11`

.NETNuGet

`SixLabors.ImageSharp` 

≥ 3.0.0&&< 3.1.11

3.1.11`dotnet add package SixLabors.ImageSharp --version 3.1.11`

## Detection & mitigation playbook

Open-source dependency

1.  ### Detect
    
    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for SixLabors.ImageSharp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
    
2.  ### Fix
    
    Update SixLabors.ImageSharp to 2.1.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-54575 is resolved across your whole dependency graph.
    
3.  ### Workarounds
    
    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
    

## Frequently Asked Questions

ImageSharp is a 2D graphics library. In versions below 2.1.11 and 3.0.0 through 3.1.10, a specially crafted GIF file containing a malformed comment extension block (with a missing block terminator) can cause the ImageSharp GIF decoder to enter an infinite loop while attempting to skip the block. This leads to a denial of service. Applications processing untrusted GIF input should upgrade to a patched version. This issue is fixed in versions 2.1.11 and 3.1.11.

O3 Security · Impact-Aware SCA

### Is CVE-2025-54575 in your dependencies?

Find it across NuGet, including transitive dependencies.

[Scan my dependencies](/book-demo) [How O3 SCA works](/impact-aware-sca)