{"id":"CVE-2024-53949","aliases":["BIT-superset-2024-53949","GHSA-35fc-9hrj-3585","PYSEC-2026-1156"],"url":"https://o3.security/vulnerability/CVE-2024-53949","summary":"Apache Superset: Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabled","details":"Improper Authorization vulnerability in Apache Superset when FAB_ADD_SECURITY_API is enabled (disabled by default). Allows for lower privilege users to use this API.\n\n issue affects Apache Superset: from 2.0.0 before 4.1.0.\n\nUsers are recommended to upgrade to version 4.1.0, which fixes the issue.","published":"2024-12-09T13:35:41.530Z","modified":"2026-10-28T02:30:33.232569128Z","cvss":null,"epss":null,"cisaKev":null,"exploitsKnown":0,"affectedPackages":[{"ecosystem":"PyPI","name":"apache-superset","fixedVersion":"4.1.0"}],"fix":{"url":"https://github.com/apache/superset/commit/7650c47e72f28559e91524f5d68d50c2060df4c7","label":"apache/superset@7650c47"},"references":[{"type":"WEB","url":"http://www.openwall.com/lists/oss-security/2024/12/09/4"},{"type":"ADVISORY","url":"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/53xxx/CVE-2024-53949.json"},{"type":"ADVISORY","url":"https://lists.apache.org/thread/d3scbwmfpzbpm6npnzdw5y4owtqqyq8d"},{"type":"ADVISORY","url":"https://nvd.nist.gov/vuln/detail/CVE-2024-53949"},{"type":"WEB","url":"https://github.com/apache/superset/commit/7650c47e72f28559e91524f5d68d50c2060df4c7"},{"type":"PACKAGE","url":"https://github.com/apache/superset"}],"provenance":{"sources":["OSV.dev","FIRST.org (EPSS)"],"lastVerified":"2026-10-28T02:30:33.232569128Z"}}