{"id":"CVE-2024-42473","aliases":["GHSA-3f6g-m4hr-59h8","GO-2024-3061"],"url":"https://o3.security/vulnerability/CVE-2024-42473","summary":"OpenFGA Authorization Bypass","details":"## Overview\n\nOpenFGA v1.5.7 and v1.5.8 are vulnerable to authorization bypass when calling Check API with a model that uses `but not` and `from` expressions and a userset. \n\n## Fix\n\n- If you are using OpenFGA within Docker or as a Go library, as a binary, or through Docker, upgrade to v1.5.9 as soon as possible\n- If using Helm chart, upgrade to 0.2.12 as soon as possible. \n\nThis fix is backward compatible.","published":"2024-08-09T21:16:17.683Z","modified":"2026-10-28T02:31:11.351178963Z","cvss":{"score":7.5,"severity":"HIGH","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N"},"epss":null,"cisaKev":null,"exploitsKnown":0,"affectedPackages":[{"ecosystem":"Go","name":"github.com/openfga/openfga","fixedVersion":"1.5.9"}],"fix":null,"references":[{"type":"ADVISORY","url":"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/42xxx/CVE-2024-42473.json"},{"type":"ADVISORY","url":"https://github.com/openfga/openfga/security/advisories/GHSA-3f6g-m4hr-59h8"},{"type":"ADVISORY","url":"https://nvd.nist.gov/vuln/detail/CVE-2024-42473"},{"type":"PACKAGE","url":"https://github.com/openfga/openfga"}],"provenance":{"sources":["OSV.dev","FIRST.org (EPSS)"],"lastVerified":"2026-10-28T02:31:11.351178963Z"}}