NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2023-6460 — @google-cloud/firestore

MEDIUMFix: googleapis/nodejs-firestore#1742

CVE-2023-6460 is a medium-severity (CVSS 4) CWE-922 vulnerability in @google-cloud/firestore. A fix is available for @google-cloud/firestore — see the affected versions and patch details below.

Information leak in nodejs-firestore

Also known asGHSA-4g6q-77j7-vvjc
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs2th percentile — riskier than 2% of all scored CVEsHighest risk
0.00%0.21%0.41%0.62%0.0%0.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

614other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@google-cloud/firestorenpm
14.3Mdownloads / week

Description

A potential logging of the firestore key via logging within nodejs-firestore exists - Developers who were logging objects through this._settings would be logging the firestore key as well potentially exposing it to anyone with logs read access. We recommend upgrading to version 6.1.0 to avoid this issue

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@google-cloud/firestoreall versions6.1.0npm install @google-cloud/firestore@6.1.0

Affected Products

1 product · 1 configurations
Application
cloud firestoregoogle
< 6.1.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @google-cloud/firestore, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @google-cloud/firestore to 6.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-6460 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A potential logging of the firestore key via logging within nodejs-firestore exists - Developers who were logging objects through this._settings would be logging the firestore key as well potentially exposing it to anyone with logs read access. We recommend upgrading to version 6.1.0 to avoid this issue
O3 Security · Impact-Aware SCA

Is CVE-2023-6460 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2023-6460: @google-cloud/firestore — Fixed in 6.1.0