{"id":"CVE-2023-32987","aliases":["GHSA-pmmr-r9v2-59p8"],"url":"https://o3.security/vulnerability/CVE-2023-32987","summary":"Jenkins Reverse Proxy Auth Plugin cross-site request forgery vulnerability","details":"Jenkins Reverse Proxy Auth Plugin 1.7.4 and earlier does not require POST requests for a form validation method, resulting in a cross-site request forgery (CSRF) vulnerability.\n\nThis vulnerability allows attackers to connect to an attacker-specified LDAP server using attacker-specified credentials.\n\nReverse Proxy Auth Plugin 1.7.5 requires POST requests for the affected form validation method.","published":"2023-05-16T16:15:11.200Z","modified":"2026-10-24T10:30:54.849243161Z","cvss":{"score":8.8,"severity":"HIGH","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"},"epss":null,"cisaKev":null,"exploitsKnown":0,"affectedPackages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:reverse-proxy-auth-plugin","fixedVersion":"1.7.5"}],"fix":null,"references":[{"type":"ADVISORY","url":"https://www.jenkins.io/security/advisory/2023-05-16/#SECURITY-3002"},{"type":"ADVISORY","url":"https://nvd.nist.gov/vuln/detail/CVE-2023-32987"}],"provenance":{"sources":["OSV.dev","FIRST.org (EPSS)"],"lastVerified":"2026-10-24T10:30:54.849243161Z"}}