{"id":"CVE-2022-31020","aliases":["GHSA-r6v9-p59m-gj2p","PYSEC-2022-265"],"url":"https://o3.security/vulnerability/CVE-2022-31020","summary":"Remote code execution in Indy's NODE_UPGRADE transaction","details":"### Impact\n\nThe `pool-upgrade` request handler in Indy-Node `<=1.12.4` allows an improperly authenticated attacker to remotely execute code on nodes within the network.\n\nNetwork operators are strongly encouraged to upgrade to the latest Indy-Node release `>=1.12.5` as soon as possible.\n\n### Patches\n\nThe `pool-upgrade` request handler in Indy-Node `>=1.12.5` has been updated to properly authenticate `pool-upgrade` transactions before any processing is performed by the request handler.  The transactions are further sanitized to prevent remote code execution.\n\n### Mitigations\n\nNetwork operators are strongly encouraged to upgrade to the latest Indy-Node release `>=1.12.5` as soon as possible.\n\n### Acknowledgements\nThank you to @shakreiner at CyberArk Labs for finding and responsibly disclosing this issue.","published":"2022-09-06T16:30:19Z","modified":"2026-10-28T02:30:34.597872694Z","cvss":{"score":8.8,"severity":"HIGH","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"},"epss":null,"cisaKev":null,"exploitsKnown":0,"affectedPackages":[{"ecosystem":"PyPI","name":"indy-node","fixedVersion":"1.12.5rc1"}],"fix":{"url":"https://github.com/hyperledger/indy-node/commit/fe507474f77084faef4539101e2bbb4d508a97f5","label":"hyperledger/indy-node@fe50747"},"references":[{"type":"WEB","url":"https://github.com/hyperledger/indy-node/releases/tag/v1.12.5"},{"type":"ADVISORY","url":"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/31xxx/CVE-2022-31020.json"},{"type":"ADVISORY","url":"https://github.com/hyperledger/indy-node/security/advisories/GHSA-r6v9-p59m-gj2p"},{"type":"ADVISORY","url":"https://nvd.nist.gov/vuln/detail/CVE-2022-31020"},{"type":"FIX","url":"https://github.com/hyperledger/indy-node/commit/fe507474f77084faef4539101e2bbb4d508a97f5"},{"type":"PACKAGE","url":"https://github.com/hyperledger/indy-node"},{"type":"WEB","url":"https://github.com/pypa/advisory-database/tree/main/vulns/indy-node/PYSEC-2022-265.yaml"}],"provenance":{"sources":["OSV.dev","FIRST.org (EPSS)"],"lastVerified":"2026-10-28T02:30:34.597872694Z"}}