{"id":"CVE-2022-29214","aliases":["GHSA-q2mx-j4x2-2h74"],"url":"https://o3.security/vulnerability/CVE-2022-29214","summary":"URL Redirection to Untrusted Site ('Open Redirect') in next-auth","details":"### Impact\n\nWe found that this vulnerability is present when the developer is implementing an OAuth 1 provider (by extension, it means Twitter, which is the only built-in provider using OAuth 1), but **upgrading** is **still recommended**.\n\n`next-auth` v3 users before version 3.29.3 are impacted. (We recommend upgrading to v4, as v3 is considered unmaintained. See our [migration guide](https://next-auth.js.org/getting-started/upgrade-v4))\n\n`next-auth` v4 users before version 4.3.3 are impacted.\n\n### Patches\n\nWe've released patches for this vulnerability in:\n  \n- v3 - `3.29.3`\n- v4 - `4.3.3`\n\nYou can do:\n\n```sh\nnpm i next-auth@latest\n```\n\nor\n\n```sh\nyarn add next-auth@latest\n```\n\nor\n\n```sh\npnpm add next-auth@latest\n```\n\n(This will update to the latest v4 version, but you can change  `latest` to `3` if you want to stay on v3.)\n\n### Workarounds\n\nIf you are not able to upgrade for any reason, you can add the following configuration to your `callbacks` option:\n\n```ts\n// async redirect(url, baseUrl) { // v3\nasync redirect({ url, baseUrl }) { // v4\n    // Allows relative callback URLs\n    if (url.startsWith(\"/\")) return `${baseUrl}${url}`\n    // Allows callback URLs on the same origin\n    else if (new URL(url).origin === baseUrl) return url\n    return baseUrl\n}\n```\n\n### References\n\nThis vulnerability was discovered right after https://github.com/nextauthjs/next-auth/security/advisories/GHSA-f9wg-5f46-cjmw was published and is very similar in nature.\n\nRead more about the `callbacks.redirect` option in the documentation: https://next-auth.js.org/configuration/callbacks#redirect-callback\n\n### For more information\n\nIf you have any concerns, we request responsible disclosure, outlined here: https://next-auth.js.org/security#reporting-a-vulnerability\n\n### Timeline\n\nThe issue was reported 2022 April 20th, a response was sent out to the reporter 8 minutes after, and a patch was produced within a few days.","published":"2022-05-20T23:45:11Z","modified":"2026-10-28T02:31:13.152535329Z","cvss":{"score":6.1,"severity":"MEDIUM","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"},"epss":null,"cisaKev":null,"exploitsKnown":0,"affectedPackages":[{"ecosystem":"npm","name":"next-auth","fixedVersion":"3.29.3"},{"ecosystem":"npm","name":"next-auth","fixedVersion":"4.3.3"}],"fix":null,"references":[{"type":"WEB","url":"https://github.com/nextauthjs/next-auth/releases/tag/next-auth%40v4.3.3"},{"type":"ADVISORY","url":"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/29xxx/CVE-2022-29214.json"},{"type":"ADVISORY","url":"https://github.com/nextauthjs/next-auth/security/advisories/GHSA-q2mx-j4x2-2h74"},{"type":"ADVISORY","url":"https://nvd.nist.gov/vuln/detail/CVE-2022-29214"},{"type":"PACKAGE","url":"https://github.com/nextauthjs/next-auth"}],"provenance":{"sources":["OSV.dev","FIRST.org (EPSS)"],"lastVerified":"2026-10-28T02:31:13.152535329Z"}}