CVE-2022-24769 is a medium-severity (CVSS 5.9) CWE-732 vulnerability in github.com/moby/moby. A fix is available for github.com/moby/moby — see the affected versions and patch details below.
Default inheritable capabilities for linux container should be empty
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/moby/moby🐹github.com/docker/dockerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A bug was found in Moby (Docker Engine) where containers were incorrectly started with non-empty inheritable Linux process capabilities, creating an atypical Linux environment and enabling programs with inheritable file capabilities to elevate those capabilities to the permitted set during execve(2). Normally, when executable programs have specified permitted file capabilities, otherwise unprivileged users and processes can execute those programs and gain the specified file capabilities up to the bounding set. Due to this bug, containers which included executable programs with inheritable file capabilities allowed otherwise unprivileged users and processes to additionally gain these inheritable file capabilities up to the container's bounding set. Containers which use Linux users and groups to perform privilege separation inside the container are most directly impacted.
This bug did not affect the container security sandbox as the inheritable set never contained more capabilities than were included in the container's bounding set.
Patches
This bug has been fixed in Moby (Docker Engine) 20.10.14. Users should update to this version as soon as possible. Running containers should be stopped, deleted, and recreated for the inheritable capabilities to be reset.
This fix changes Moby (Docker Engine) behavior such that containers are started with a more typical Linux environment. Refer to capabilities(7) for a description of how capabilities work. Note that permitted file capabilities continue to allow for privileges to be raised up to the container's bounding set and that processes may add capabilities to their own inheritable set up to the container's bounding set per the rules described in the manual page. In all cases the container's bounding set provides an upper bound on the capabilities that can be assumed and provides for the container security sandbox.
Workarounds
The entrypoint of a container can be modified to use a utility like capsh(1) to drop inheritable capabilities prior to the primary process starting.
Credits
The Moby project would like to thank Andrew G. Morgan for responsibly disclosing this issue in accordance with the Moby security policy.
For more information
If you have any questions or comments about this advisory:
- Open an issue
- Email us at [email protected] if you think you’ve found a security bug
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/moby/moby | all versions | 20.10.14go get github.com/moby/moby@v20.10.14 |
| 🐹Go | github.com/docker/docker | all versions | 20.10.14go get github.com/docker/docker@v20.10.14 |
Affected Products
debian linuxdebianfedorafedoraprojectrunclinuxfoundationmobymobyprojectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/moby/moby, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/moby/moby to 20.10.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-24769 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The entry point of a container can be modified to use a utility like capsh(1) to drop inheritable capabilities prior to the primary process starting.Source: Red Hat security advisory for CVE-2022-24769 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift Container Platform 4.10 | openshift4/ose-local-storage-diskmaker:v4.10.0-202204090935.p0.g4b31438.assembly.stream | RHSA-2022:1357 |
| Red Hat OpenShift Container Platform 4.6 | openshift4/ose-local-storage-operator:v4.6.0-202204261127.p0.g6cc1fff.assembly.stream | RHSA-2022:1622 |
| Red Hat OpenShift Container Platform 4.6 | openshift4/ose-local-storage-diskmaker:v4.6.0-202205020737.p0.g6cc1fff.assembly.stream | RHSA-2022:2265 |
| Red Hat OpenShift Container Platform 4.7 | openshift4/ose-local-storage-diskmaker:v4.7.0-202204252136.p0.gd6211c0.assembly.stream | RHSA-2022:1699 |
| Red Hat OpenShift Container Platform 4.8 | openshift4/ose-local-storage-diskmaker:v4.8.0-202204111736.p0.g50982c6.assembly.stream | RHSA-2022:1370 |
| Red Hat OpenShift Container Platform 4.9 | openshift4/ose-local-storage-diskmaker:v4.9.0-202204091605.p0.g4ab612d.assembly.stream | RHSA-2022:1363 |
Frequently Asked Questions
Is CVE-2022-24769 in your dependencies?
Find it across Go, including transitive dependencies.