# CVE-2022-23942: pydoris Info Disclosure — Fixed in 1.0.0

🐍

🐍 PyPI

Not in CISA KEV

HIGH severity

# CVE-2022-23942 — pydoris

HIGH 

CVE-2022-23942 is a high-severity (CVSS 7.5) Hard-coded Credentials vulnerability in pydoris. A fix is available for pydoris — see the affected versions and patch details below.

Apache Doris hardcoded key and IV

Also known asPYSEC-2022-43150

Published

Apr 27, 2022

Updated

Nov 22, 2024

Affected

1 pkg

Patched

1 / 1

Exploits

None indexed

Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

## EPSS Exploitation Probability

[via FIRST.org ↗](https://www.first.org/epss/)

3.4%probability of exploitation in next 30 days

Lower Risk0.00%

Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk

1.31%2.19%3.07%3.95%1.8%3.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from [FIRST.org EPSS](https://www.first.org/epss/).

## How urgent is this, really

## Where this sits among everything scored

## Real-World Exposure

1 pkg affected

🐍`pydoris`

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

## Description

Apache Doris, prior to 1.0.0, used a hardcoded key and IV to initialize the cipher used for ldap password, which may lead to information disclosure.

## Affected Packages

1 total 1 fixed

Ecosystem

Package

Vulnerable range

Fix

🐍PyPI

`pydoris` 

all versions

1.0.0`pip install --upgrade 'pydoris==1.0.0'`

## Affected Products

1 product · 1 configurations

Application

`doris`apache

< 1.0.0

range

## Detection & mitigation playbook

Open-source dependency

1.  ### Detect
    
    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pydoris, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
    
2.  ### Fix
    
    Update pydoris to 1.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-23942 is resolved across your whole dependency graph.
    
3.  ### Workarounds
    
    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
    

## Frequently Asked Questions

Apache Doris, prior to 1.0.0, used a hardcoded key and IV to initialize the cipher used for ldap password, which may lead to information disclosure.

O3 Security · Impact-Aware SCA

### Is CVE-2022-23942 in your dependencies?

Find it across PyPI, including transitive dependencies.

[Scan my dependencies](/book-demo) [How O3 SCA works](/impact-aware-sca)