NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2020-7009 — elasticsearch

HIGH

CVE-2020-7009 is a high-severity (CVSS 8.8) CWE-266 vulnerability in org.elasticsearch:elasticsearch. A fix is available for org.elasticsearch:elasticsearch — see the affected versions and patch details below.

Improper Privilege Management in Elasticsearch

Also known asBIT-elasticsearch-2020-7009GHSA-gfv5-grx2-9jw2
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.00%0.79%1.59%2.38%0.6%1.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.elasticsearch:elasticsearch☕org.elasticsearch:elasticsearch

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.elasticsearch:elasticsearch≥ 6.7.0&&< 6.8.86.8.8org.elasticsearch:elasticsearch:6.8.8
☕Mavenorg.elasticsearch:elasticsearch≥ 7.0.0&&< 7.6.27.6.2org.elasticsearch:elasticsearch:7.6.2

Affected Products

1 product · 2 configurations
Application
elasticsearchelastic
≥ 7.0.0 && < 7.6.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.elasticsearch:elasticsearch, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.elasticsearch:elasticsearch to 6.8.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-7009 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.
O3 Security · Impact-Aware SCA

Is CVE-2020-7009 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-7009: elasticsearch PrivEsc — Fixed in 6.8.8