{"id":"CVE-2019-5815","aliases":["GHSA-vmfx-gcfq-wvm2"],"url":"https://o3.security/vulnerability/CVE-2019-5815","summary":"Nokogiri implementation of libxslt vulnerable to heap corruption","details":"Type confusion in `xsltNumberFormatGetMultipleLevel` prior to libxslt 1.1.33 could allow attackers to potentially exploit heap corruption via crafted XML data.\n\nNokogiri prior to version 1.10.5 contains a vulnerable version of libxslt. Nokogiri version 1.10.5 upgrades the dependency to libxslt 1.1.34, which contains a patch for this issue.","published":"2019-12-11T01:15:10.537Z","modified":"2026-10-29T07:19:17.997615490Z","cvss":{"score":7.5,"severity":"HIGH","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"},"epss":null,"cisaKev":null,"exploitsKnown":1,"affectedPackages":[{"ecosystem":"RubyGems","name":"nokogiri","fixedVersion":"1.10.5"}],"fix":null,"references":[{"type":"WEB","url":"https://bugs.chromium.org/p/chromium/issues/detail?id=930663"},{"type":"WEB","url":"https://lists.debian.org/debian-lts-announce/2022/09/msg00010.html"},{"type":"FIX","url":"https://gitlab.gnome.org/GNOME/libxslt/commit/08b62c25871b38d5d573515ca8a065b4b8f64f6b"},{"type":"ADVISORY","url":"https://nvd.nist.gov/vuln/detail/CVE-2019-5815"},{"type":"WEB","url":"https://github.com/sparklemotion/nokogiri/issues/2630"},{"type":"WEB","url":"https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/CVE-2019-5815.yml"},{"type":"PACKAGE","url":"https://github.com/sparklemotion/nokogiri"}],"provenance":{"sources":["OSV.dev","FIRST.org (EPSS)"],"lastVerified":"2026-10-29T07:19:17.997615490Z"}}