{"id":"CVE-2017-1000469","aliases":["GHSA-96hw-v598-jvgh","PYSEC-2026-314"],"url":"https://o3.security/vulnerability/CVE-2017-1000469","summary":"Cobbler vulnerable to arbitrary code execution","details":"Cobbler version up to 2.8.2 is vulnerable to a command injection vulnerability in the \"add repo\" component resulting in arbitrary code execution as root user.","published":"2018-01-03T20:29:00.360Z","modified":"2026-10-20T10:47:36.863676718Z","cvss":{"score":9.8,"severity":"CRITICAL","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"},"epss":null,"cisaKev":null,"exploitsKnown":1,"affectedPackages":[{"ecosystem":"PyPI","name":"cobbler","fixedVersion":"3.0.0"}],"fix":{"url":"https://github.com/cobbler/cobbler/commit/4b20397425a5d42a2d8927233654f4d7435bd4c2","label":"cobbler/cobbler@4b20397"},"references":[{"type":"REPORT","url":"https://github.com/cobbler/cobbler/issues/1845"},{"type":"ADVISORY","url":"https://nvd.nist.gov/vuln/detail/CVE-2017-1000469"},{"type":"WEB","url":"https://github.com/cobbler/cobbler/commit/4b20397425a5d42a2d8927233654f4d7435bd4c2"},{"type":"PACKAGE","url":"https://github.com/cobbler/cobbler"},{"type":"WEB","url":"https://github.com/pypa/advisory-database/tree/main/vulns/cobbler/PYSEC-2026-314.yaml"},{"type":"WEB","url":"https://pypi.org/project/cobbler"}],"provenance":{"sources":["OSV.dev","FIRST.org (EPSS)"],"lastVerified":"2026-10-20T10:47:36.863676718Z"}}