{"id":"CVE-2017-1000426","aliases":["GHSA-g4rw-82hq-8jpr","PYSEC-2026-841"],"url":"https://o3.security/vulnerability/CVE-2017-1000426","summary":"MapProxy vulnerable to cross-site scripting in demo service","details":"MapProxy version 1.11.1 and older are vulnerable to cross-site scripting in the demo service resulting in possible information disclosure. An incomplete fix was released in v[1.10.4](https://github.com/mapproxy/mapproxy/issues/322#issuecomment-518573169), and a complete fix was released in v[1.11.1](https://github.com/mapproxy/mapproxy/commit/436c8f489761d1b4ee22b2440b53cc96bbc28aea).","published":"2018-01-02T21:29:00.203Z","modified":"2026-10-20T10:47:35.086196401Z","cvss":{"score":6.1,"severity":"MEDIUM","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"},"epss":null,"cisaKev":null,"exploitsKnown":1,"affectedPackages":[{"ecosystem":"PyPI","name":"mapproxy","fixedVersion":"1.11.1"}],"fix":{"url":"https://github.com/mapproxy/mapproxy/commit/420412aad45171e05752007a0a2350c03c28dfd8","label":"mapproxy/mapproxy@420412a"},"references":[{"type":"FIX","url":"https://github.com/mapproxy/mapproxy/issues/322"},{"type":"ADVISORY","url":"https://nvd.nist.gov/vuln/detail/CVE-2017-1000426"},{"type":"WEB","url":"https://github.com/mapproxy/mapproxy/commit/420412aad45171e05752007a0a2350c03c28dfd8"},{"type":"WEB","url":"https://github.com/mapproxy/mapproxy/commit/436c8f489761d1b4ee22b2440b53cc96bbc28aea"},{"type":"PACKAGE","url":"https://github.com/mapproxy/mapproxy"}],"provenance":{"sources":["OSV.dev","FIRST.org (EPSS)"],"lastVerified":"2026-10-20T10:47:35.086196401Z"}}